TS 6.6 and doubleclicking a *.scn file

About Truespace Archives

These pages are a copy of the official truespace forums prior to their removal somewhere around 2011.

They are retained here for archive purposes only.

TS 6.6 and doubleclicking a *.scn file // TS6 and Older

1  |  

Post by Tiles // Sep 18, 2007, 11:22pm

Tiles
Total Posts: 1037
pic
After reinstalling TS 6.6 i am not longer able to open a *.scn file by doubleclicking at it. But it worked before. Now it simply opens with a New Scene instead the scene i try to open, and at some scenes with an Bad Input Data Error. But when i load the scenes from the File menu they load fine. And yes, i have still reinstalled it again to see if this fixed it. It didn't. Any ideas?

Post by TheWickedWitchOfTheWeb // Sep 19, 2007, 1:25am

TheWickedWitchOfTheWeb
Total Posts: 858
pic
Right click the *.scn file, choose 'open with', select truespace checking the 'always use the selected program...' checkbox? Any good?

Post by Tiles // Sep 19, 2007, 3:33am

Tiles
Total Posts: 1037
pic
Not really. TS 6.6 still IS opening with a double click at an *.scn file. It is just that it doesn't load the scene by it ;)

Post by TheWickedWitchOfTheWeb // Sep 19, 2007, 4:18am

TheWickedWitchOfTheWeb
Total Posts: 858
pic
Sorry, misread the inital question. In that case... no idea. I know this happened with tS 7 and up but don't recall having the problem with 6.6.


Just a thought, have you also got 7.* installed? maybe that's caused it as double click .scn files opens the program but not the scene?

Post by Tiles // Sep 19, 2007, 6:43am

Tiles
Total Posts: 1037
pic
Sure i have. TS 7.51 is installed too. But i had this one also installed before. Without this problems. I really wonder where the problem is. Ah this evil Windows reinstalling ...


Anyway, thank you for your help :)

Post by Tiles // Sep 20, 2007, 10:51pm

Tiles
Total Posts: 1037
pic
Got it back working. But don't ask me how. It simply started working again after several tries with playing around to open it with TS 7.51 and 6.6. :banana:

Post by Norm // Sep 21, 2007, 5:30am

Norm
Total Posts: 862
pic
How many trueSpace entries are there when you right-click a scn file and check out it's properties? General tab/Change button shows a list. I have three here in mine. Could be you set trueSpace7 to open this particular scene file and the others remain because they were not changed. It is possible with windows for this to happen. You have to look at it like this, scn is ts6.6 and RsScn is trueSpace7.5 ...

Post by Tiles // Sep 22, 2007, 9:01pm

Tiles
Total Posts: 1037
pic
Norm, thanks for your reply. But i think i know the difference between scn and rsscn. And it happens to all scn files. Not just to a specific one.

Anyway, got it tracked down. Definitely TS 7.51 overriding TS 6.6. But not in a way it is meant to be.

I had uninstalled everything TS because of my trouble with the Thumbnailviewer and cleaned the registry then. Then i installed TS 6.6. Double clicking a scn file opened this scene in TS 6.6 as it should. My barrel is present.

Then i installed TS 7.51. Now a click at a scn file opened TS 7.5, giving me a warning, and didn't open the scn at all.

Reassigning TS 6.6 to open with a scn file now opens TS 6.6 without opening the scn file. I was back to my initial problem ... :rolleyes:

http://reinerstileset.4players.de/ext/openwithts66.jpg

http://reinerstileset.4players.de/ext/openwithts66_2.jpg

I had to do some wired stuff to get it back working. First i had to assign TS 7.51 back. Then Editor. And finally TS 6.6. And then it was back working as it should.

http://reinerstileset.4players.de/ext/openwithts66_fix1.jpg

http://reinerstileset.4players.de/ext/openwithts66_fix2.jpg

http://reinerstileset.4players.de/ext/openwithts66_fix3.jpg

http://reinerstileset.4players.de/ext/openwithts66_fix4.jpg

My guess is that TS 6.6 and TS 7.51 are partially handled as one app in this case, conflicting somehow. And so it is necessary to assign the file to a completely different app when changing the way which app should open with a scn file.

Post by Emmanuel // Sep 22, 2007, 9:23pm

Emmanuel
Total Posts: 439
pic
I confirm scn files never load in tS7.5 on a double-clic in Windows Explorer.

Here, with XP PRo 64, if I double clic a scn file, I get tS7.5 to launch, but the scene does not load. I get the error message below instead.

It would be nice to get that one fixed for tS7.6 : double-clic a scn file should definately load the scene in Modeler...

Post by trueBlue // Sep 22, 2007, 9:27pm

trueBlue
Total Posts: 1761
pic
Hey ya Tiles...long time no say hi. ;)
Hope this will help.
In Windows Explorer select Tools/Folder Options.
In Folder Options go to File Types and scroll to find and select SCN and then select Advance.
In Edit File Type select Edit.
In Editing action for type: Caligari trueSpace Scene make sure it is pointed to C:\trueSpace6\tS6.exe %1 or whatever yours is.

I do not have tS6.6 installed here so I am not sure but make sure the %1 is behind the EXE after one space in between. You can select the Browse button too. But I think the key here is the Action = Open and the %1

Hope this helps.

This seems to happen when uninstalling one or the other. I got rid of that Thumbnail viewer within a week of use. I had a similar problems.

Post by Tiles // Sep 22, 2007, 9:55pm

Tiles
Total Posts: 1037
pic
Yeah, long time not talked. Was a bit out of order and so inactive the last weeks.


Thanks for your tips. But currently no need to dive again into it. Everything is finally back working now. Both, the Thumbnail Viewer, and opening a scn file with TS 6.6. Phew. Has kept me busy for a pretty while :)


Emmanuel, the behaviour of TS 7.5 that it doesn't open the scene is a know issue. But i hope that the bridge and the modeler disappears in the next version/s. And then this issue is gone anyway :D
Awportals.com is a privately held community resource website dedicated to Active Worlds.
Copyright (c) Mark Randall 2006 - 2022. All Rights Reserved.
Awportals.com   ·   ProLibraries Live   ·   Twitter   ·   LinkedIn